It is currently Fri Jan 17, 2020 9:58 pm


Post a new topicPost a reply Page 1 of 1   [ 12 posts ]
Author Message
 Post subject: 1ST MOT AND... FAILED MISERABLY!
PostPosted: Fri Nov 21, 2014 4:33 pm 
Registered User
Registered User

Joined: Fri Mar 14, 2014 8:13 pm
Posts: 12
Gender: Female
Car: TWINGO SILVERSTONE
I've had my 33/50 for 8 months and have only driven 1,935 miles. Service not due before March 2015 (or 24,005 miles) but as she had to be MOTed on Dec. 11th, took her to a Renault dealership yesterday for both MOT and service.
Phone call this morning from the garage... failed! :x
Failed on suspension joints, apparently due to cover failure allowing the ingress of dirt.
Not impressed! The car has only done 19,198 miles since brand new!
Will be comforted if the warranty pays up as the Renault dealer assured me. Otherwise he said it would cost me £500 for those bits alone!
I am gutted! Such a low mileage and the ball joints playing up!?
On top of it all, because it is the weekend, he will not have the parts before Tuesday.

Let's hope that the warranty will indeed cover the cost...


Top
 Profile  
 
 Post subject: Re: 1ST MOT AND... FAILED MISERABLY!
PostPosted: Fri Nov 21, 2014 4:42 pm 
Registered User
Registered User
User avatar

Joined: Sun Apr 24, 2011 4:53 am
Posts: 842
Location: Belgium
Car: Twingo Gordini RS N°880
they will and if you have read a bit on our forums you will know it is a little "child" disease with the Twingo RS ;) , even if they do not make it under warrenty talk on this
post on our forum they will gladly help you around or maybe read a bit more to see what other people did to get it fixed ;)

suspension-and-brakes/suspension-bushings-t2955.html?hilit=balljoints


Top
 Profile  
 
 Post subject: Re: 1ST MOT AND... FAILED MISERABLY!
PostPosted: Fri Nov 21, 2014 4:45 pm 
Twingo133.net Co-Owner
Twingo133.net Co-Owner
User avatar

Joined: Mon Feb 07, 2011 12:04 am
Posts: 7190
Location: Moray
Car: Gordini 133 #159
Its a fairly well known fault and RUK have been quite good sorting it out. Even covering part of the cost for a few which were out of warranty.


Top
 Profile  
 
 Post subject: Re: 1ST MOT AND... FAILED MISERABLY!
PostPosted: Fri Nov 21, 2014 5:54 pm 
Registered User
Registered User
User avatar

Joined: Fri Oct 28, 2011 9:03 am
Posts: 2114
Location: west wickham
Car: twingo 133 + cup
sorry to hear it failed, i told my mechanic to check mine before mot and he laughed saying they wouldn't fail especially as it had only done 13k, he took all his words back after he checked :P

neil, yes they have been good at replacing, still annoys me they say there isn't a problem or an upgraded part last time i checked :S see how long these ones last


Top
 Profile  
 
 Post subject: Re: 1ST MOT AND... FAILED MISERABLY!
PostPosted: Fri Nov 21, 2014 8:52 pm 
Registered User
Registered User

Joined: Fri Mar 14, 2014 8:13 pm
Posts: 12
Gender: Female
Car: TWINGO SILVERSTONE
GhostZ wrote:
they will and if you have read a bit on our forums you will know it is a little "child" disease with the Twingo RS ;) , even if they do not make it under warrenty talk on this
post on our forum they will gladly help you around or maybe read a bit more to see what other people did to get it fixed ;)

suspension-and-brakes/suspension-bushings-t2955.html?hilit=balljoints


Thank you GhostZ. I had read several articles on this site but nothing related to the Twingo Silverstone in particular. I learnt even more with the link you included!
I am not very optimistic though as someone wrote he/she had the trick happened 3 times to him/her!

Anyway, as I've left my car at the garage till they fix it when they receive the part on Tuesday, I shall see what they come up with.


Top
 Profile  
 
 Post subject: Re: 1ST MOT AND... FAILED MISERABLY!
PostPosted: Fri Nov 21, 2014 8:54 pm 
Registered User
Registered User

Joined: Fri Mar 14, 2014 8:13 pm
Posts: 12
Gender: Female
Car: TWINGO SILVERSTONE
singlespeed wrote:
Its a fairly well known fault and RUK have been quite good sorting it out. Even covering part of the cost for a few which were out of warranty.


Again, reading the forums I am not impressed with my Renault service manager who said he was very surprised at the failure of these ball joints.


Top
 Profile  
 
 Post subject: Re: 1ST MOT AND... FAILED MISERABLY!
PostPosted: Fri Nov 21, 2014 8:56 pm 
Registered User
Registered User

Joined: Fri Mar 14, 2014 8:13 pm
Posts: 12
Gender: Female
Car: TWINGO SILVERSTONE
manofhow wrote:
sorry to hear it failed, i told my mechanic to check mine before mot and he laughed saying they wouldn't fail especially as it had only done 13k, he took all his words back after he checked :P

neil, yes they have been good at replacing, still annoys me they say there isn't a problem or an upgraded part last time i checked :S see how long these ones last



Thanks for the condoleances :) Just seems a bit of a bummer if every year I have to replace these ball joints!


Top
 Profile  
 
 Post subject: Re: 1ST MOT AND... FAILED MISERABLY!
PostPosted: Sat Nov 22, 2014 8:35 am 
Twingo133.net Co-Owner
Twingo133.net Co-Owner
User avatar

Joined: Mon Feb 07, 2011 12:04 am
Posts: 7190
Location: Moray
Car: Gordini 133 #159
The replacements with -A embossed into the arm seem to be much better :)


Top
 Profile  
 
 Post subject: Re: 1ST MOT AND... FAILED MISERABLY!
PostPosted: Sat Nov 22, 2014 1:11 pm 
Registered User
Registered User
User avatar

Joined: Sat Jun 15, 2013 2:17 pm
Posts: 100
Location: Slovenia
Gender: Male
Car: Twingo RS Cup
For extra protection you could install ball joint cover shields, they are quite cheap (I don't remember the price but they all together came up to about 15€).

suspension-and-brakes/lower-balljoint-shield-t12234.html


Top
 Profile  
 
 Post subject: Re: 1ST MOT AND... FAILED MISERABLY!
PostPosted: Tue Nov 25, 2014 8:31 pm 
Registered User
Registered User

Joined: Fri Mar 14, 2014 8:13 pm
Posts: 12
Gender: Female
Car: TWINGO SILVERSTONE
Well, at least some good news.
Got my car back today. Renault did pay for the wishbone.
We (my partner and I) also saw the damaged joint; it was badly split and totally degraded.

By any chance, does anybody know the email address of Renault custom service, please?


Top
 Profile  
 
 Post subject: Re: 1ST MOT AND... FAILED MISERABLY!
PostPosted: Tue Jan 27, 2015 8:14 am 
Registered User
Registered User
User avatar

Joined: Sat Oct 30, 2010 8:48 am
Posts: 2119
Car: 133 & 172 & 225
My 133 Gordini had the exact same problem around the first MOT and Renault fixed it a month out of warranty. Car had 1,000 miles on the clock at the time.


Top
 Profile  
 
 Post subject: Re: 1ST MOT AND... FAILED MISERABLY!
PostPosted: Tue Jan 27, 2015 11:39 am 
Registered User
Registered User

Joined: Fri Mar 14, 2014 8:13 pm
Posts: 12
Gender: Female
Car: TWINGO SILVERSTONE
Yet another one! And then Renault says it's very unusual. What a joke!


Top
 Profile  
 
Display posts from previous:  Sort by  
Post a new topicPost a reply Page 1 of 1   [ 12 posts ]


Who is online

Users browsing this forum: CHIPPY, Jgyw133, jlxd91, OllieG and 8 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  


Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
610nm Style by Daniel St. Jules of Gamexe and modified by Matt of Twingo133.net


phpBB SEO